System Requirements

Last Modified: February 28, 2016

Records requires macOS 10.11 or higher, and will run fine on any Mac that's supported by these macOS versions. As databases get more complex though, involving multiple forms, fields and thousand of records, a powerful Mac with more RAM will definitely help. Please download our free trial to test the performance before you purchase.